angular


UNMET PEER DEPENDENCY error installing #angular/animations


I am trying to install #angular/animations. Apparently, this is a dependency of #angular/material as I am getting GET http://localhost:3000/#angular/animations 404 (Not Found) since installing material.
I am getting this error installing it:
> npm install #angular/animations --save
angular-quickstart#1.0.0 D:\My Documents\Visual Studio
2017\Projects\materialtest\frontend
+-- #angular/animations#4.1.2
`-- UNMET PEER DEPENDENCY #angular/core#4.0.3
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents#^1.0.0
(node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for
fsevents#1.1.1: wanted {"os":"darwin","arch":"any"} (current:
{"os":"win32","arch":"x64"})
npm WARN #angular/animations#4.1.2 requires a peer of #angular/core#4.1.2 but none was installed.
This seems to be telling me that I need version 4.0.3 of core. But it also says I need 4.1.2. I have 4.0.3. Here is the output of my npm outdated:
Package Current Wanted Latest Location
#angular/common 4.0.3 4.0.3 4.1.2 angular-quickstart
#angular/compiler 4.0.3 4.0.3 4.1.2 angular-quickstart
#angular/core 4.0.3 4.0.3 4.1.2 angular-quickstart
#angular/forms 4.0.3 4.0.3 4.1.2 angular-quickstart
#angular/http 4.0.3 4.0.3 4.1.2 angular-quickstart
#angular/platform-browser 4.0.3 4.0.3 4.1.2 angular-quickstart
#angular/platform-browser-dynamic 4.0.3 4.0.3 4.1.2 angular-quickstart
#angular/router 4.0.3 4.0.3 4.1.2 angular-quickstart
#types/jasmine 2.5.36 2.5.36 2.5.47 angular-quickstart
#types/node 6.0.73 6.0.73 7.0.18 angular-quickstart
jasmine-core 2.4.1 2.4.1 2.6.1 angular-quickstart
protractor 4.0.14 4.0.14 5.1.2 angular-quickstart
rxjs 5.0.1 5.0.1 5.4.0 angular-quickstart
systemjs 0.19.40 0.19.40 0.20.12 angular-quickstart
tslint 3.15.1 3.15.1 5.2.0 angular-quickstart
typescript 2.1.6 2.1.6 2.3.2 angular-quickstart
Also, #angular/animations are already in my package.json: "#angular/animations": "^4.1.2", but the folder does not exist.
So how do I get animations installed? Do I need to update Angular, even though I just installed the latest angular-quickstart today? Is so, how? This post on how did not work for me (maybe because I am on windows?)
Or am I on the wrong path - all I want right now is #angular/material working so I can continue on my tutorial.
Angular needs every package of #angular to be in the same version(not must but need). Since you set #angular/animations to the latest version(v4.1.2), you have to edit your package.json and change packages of #angular to 4.1.2 and run npm install. Or else just install each of them manually by npm i #angular/xxx#latest --save.

Related Links

Uncaught ReferenceError: define is not defined angular2/webpack 1
unable to find suitable angular data grid for angular 2.4.1 version?
Access process.env in environment.ts file created from the angular-cli
Cannot read property 'channels' of undefined youtube api
How to set the public path on angular 4
Using local Bootstrap3 with angular 2
Firebase: update database when no write operation happens in 5 minutes interval
Build single directive to perform both Structural & Attribute behaviour?
Angular 2 Sending data to child
AOT - Function calls are not supported Module.forRoot
subscribe to ionic page change event
Dynamic number of Promise in Angularfire2
Drag and drop doesn't call change event in ie/edge angular2
Angular2 routing issue and ngOnInit called twice
angular 2.4.1 on IE10- dont work 4 me
Angular 2 MVW - MVC, MVA, MVP, MVVM?

Categories

HOME
menu
momentjs
ruby-on-rails-4
multidimensional-array
hardware
jupyter-notebook
caffe
boost
timezone
c#-3.0
amazon-sqs
geometry
shoutem
sourceforge
angularjs-ng-transclude
dijkstra
mit-scratch
affinity
video-processing
sirikit
rinsim
libcurl
azure-storage-blobs
stackdriver
media
fgets
mdm
silex
vowpalwabbit
lwip
podcast
required
aircrack-ng
word
tensorflow-serving
webmin
transitions
dreamhost
fixture
inline
oclazyload
interstitial
parasoft
modelio
friend-function
webrole
generated
django-compressor
equation
angularjs-service
google-keep
istanbul
libtool
rpy2
audio-player
azure-webjobssdk
canonical-link
motorola
code-collaborator
htsql
parrot
owner
jodconverter
giflib
throttle
kdiff3
customdialog
mime-mail
struts2-jquery-grid
dfdl
iterm
r1soft
cirqus
yard
fedora-commons
busy-waiting
approximation
bpopup
streaminsight
dotdotdot
zipcode
ncbi
google-text-to-speech
enplug-sdk
irssi
mysql-error-1093
arbitrary-precision
mathgl
nsfontmanager
android-3.0-honeycomb
harfbuzz
tiles2
system.speech.recognition
jquery-ui-selectable
wexitstatus
trusted-timestamp
mercurial-subrepos
nservicebus3
generic-list
mono-service
assetslibrary
webarchive
ubuntu-9.10
cloning
xcode4.1
tao
widechar
comdlg32
pia

Resources

Mobile Apps Dev
Database Users
javascript
java
csharp
php
android
MS Developer
developer works
python
ios
c
html
jquery
RDBMS discuss
Cloud Virtualization
Database Dev&Adm
javascript
java
csharp
php
python
android
jquery
ruby
ios
html
Mobile App
Mobile App
Mobile App